Can-Am Spyder Forums banner
1 - 20 of 26 Posts

·
Registered
Joined
·
504 Posts
Discussion Starter · #1 ·
I guess the title kind of gives away what happened yesterday. Yesterday was the first day since I got the DPS replaced to go out and actually ride. It was about 56 degrees and I had ridden about 20-25 miles when the bike icon with the squigly lines under it lit up, the message in the title started accross the screen and the limp home mode kicked in. The thing is I was traveling on straight flat ground at about 55 to 60 when this happened.

My thinking is that something didn't get plugged in tight when the dealer was replacing the DPS as I did find a number of loose screws when I took the front off to change the sway bar.

I will be taking time off work to get it up to the dealer tommorow but it is a shame as today is another great day I would have prefered to go for a ride instead of cleaning the yard.
 

·
Registered
Joined
·
42 Posts
Corybud,
Every time I take my RS into the dealer to have work done, without fail, something is left unplugged, and have to take it back. It just seems to be par for the course.
 

·
Registered
Joined
·
504 Posts
Discussion Starter · #3 ·
It is kind of annoying to have that happen especially when you pay shop rates that are not cheap. I had the 600 mile service done at the same time they replaced the DPS and charged me $305.00.

Saturday I was going to put the floor boards on but it was so nice for a change I just wanted to ride. Today I limped up to the dealer and got the dreaded "We are kind of backed up" so............I guess it's anybody's guess when I'll get it back.
 

·
Registered
Joined
·
35 Posts
I also got the dreaded "VSS Error Check DPS - Limp Home Mode" as soon as I tried out the newly replaced DPS unit. They checked it over and could find nothing wrong. They told me something about needing to drive it around for it o reset. Sadly, that didn't work either. I've dropped my Spyder back off at the dealer. I wonder if I got a bad DPS unit as part of the recall.
 

·
Registered
Joined
·
504 Posts
Discussion Starter · #5 ·
So did they re-set the computer when you first took it back and how long did it take to error out again or did they send you off again with the DPS error?
 

·
Registered
Joined
·
35 Posts
After installing the replacement DPS from Can-Am, they reset the computer and test-drove it, but not long enough for the error code to come on. That can take up 10-20 minutes, although it has also come on within two minutes of starting up. I'll post what happens following this latest trip back to the dealer.
 

·
Registered
Joined
·
504 Posts
Discussion Starter · #7 ·
My dealer called me this afternoon and said that the computer needed some adjustment to be compatable with the new DPS unit. I hope that this is the case and weather permitting will pick it up tommorow. I will let you know if this fixes the issue.

Thanks

Mike
 

·
Registered
Joined
·
39 Posts
Always make sure you're dealer has the latest BUDS software updates! Ask them to verify! Also, the problems you encountered could be solved with a simple recalibration of the DPS. It take 2 minutes and two people to do it. :D
 

·
Registered
Joined
·
504 Posts
Discussion Starter · #9 ·
Thanks for the info. I was pretty sure it had something to do with the new DPS since I never had any problems prior to having that changed out. I will check with the dealer regarding their software update.

Thanks again

Mike
 

·
Premium Member
Joined
·
3,861 Posts

·
Registered
Joined
·
504 Posts
Discussion Starter · #11 ·
Hi Bob,

That's exactly what the dealer said when I picked my spyder up this morning. It's about 10 miles from the dealer to my house and so far no problems.

Mike
 

·
Registered
Joined
·
1 Posts
DPS -Limp Home

I had my DPS replaced due to the recall and was able to ride my Spyder once before it limped home. My bke has been in the shop now for 5 weeks. 30 different error messages appeared and they keep replacing part after part after part with no luck on being fixed.
 

·
Registered
Joined
·
504 Posts
Discussion Starter · #17 ·
This is some advise I received regarding my spyder and the limp home problem after I had my DPS replaced.

Hope it helps

Not sure where you or you dealer are located but the person to talk to is lou at pirate power sports, he is the guy that trained many of the techs at dealers to install to new units. He nows the spyder inside and out. If your guys need help to figure it out, have them contact him. He is super helpfull. he is in riverside ca. [email protected]
 

·
Registered
Joined
·
7 Posts
I guess the title kind of gives away what happened yesterday. Yesterday was the first day since I got the DPS replaced to go out and actually ride. It was about 56 degrees and I had ridden about 20-25 miles when the bike icon with the squigly lines under it lit up, the message in the title started accross the screen and the limp home mode kicked in. The thing is I was traveling on straight flat ground at about 55 to 60 when this happened.

My thinking is that something didn't get plugged in tight when the dealer was replacing the DPS as I did find a number of loose screws when I took the front off to change the sway bar.

I will be taking time off work to get it up to the dealer tommorow but it is a shame as today is another great day I would have prefered to go for a ride instead of cleaning the yard.
I have exactly the same error messages, what was the solution and had the dealer offered any real information re their clearing of the errors???
 

·
Registered
Joined
·
6 Posts
Dps error on 2011 rt

I thought the DPS problem was fixed. I picked up our new spider RT on Monday. I rode it to work on Thrusday. The wife and I started out Sat. to do a all day ride. Well that is whyat our plans were. Our first stop was to be at the dealer to pick up our new CAN AM helments. The dealer is 50 miles from our house. At 18 miles going over the Shands bridge that crosses the St. Johns river the DPS warning came on the bike lost power and then the check engine light came on. We drove the rest of the way to the dealer in limp home mode. When the light came on we had 118 miles on the bike. When we got to the dealer they said they could not check it out because the factorys was doing maint. on there computer and it was shut down for the weekend. When we purshased the RT the dealer told us that the clutch and dps problems were resolved and our 2011 would not have these problems. So much for the no problems. If this happens again the dealer is going to get it back. Will find out tomorrow what they found. I sure hope this is a one time problem because we really love the RT.
 

·
Registered
Joined
·
377 Posts
I thought the DPS problem was fixed. I picked up our new spider RT on Monday. I rode it to work on Thrusday. The wife and I started out Sat. to do a all day ride. Well that is whyat our plans were. Our first stop was to be at the dealer to pick up our new CAN AM helments. The dealer is 50 miles from our house. At 18 miles going over the Shands bridge that crosses the St. Johns river the DPS warning came on the bike lost power and then the check engine light came on. We drove the rest of the way to the dealer in limp home mode. When the light came on we had 118 miles on the bike. When we got to the dealer they said they could not check it out because the factorys was doing maint. on there computer and it was shut down for the weekend. When we purshased the RT the dealer told us that the clutch and dps problems were resolved and our 2011 would not have these problems. So much for the no problems. If this happens again the dealer is going to get it back. Will find out tomorrow what they found. I sure hope this is a one time problem because we really love the RT.
I have had no problems whatsoever with my 2009 RS SM5. We were thinking of getting an RT but I keep hearing stories of problems with them so now I am in a holding pattern. It makes no difference if BRP honors all warranty repairs - if you're out on the road somewhere and a problem develops that is little consolation. On top of that you may not be close to a Can Am dealer. David
 
1 - 20 of 26 Posts
Top