Can-Am Spyder Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
My 3 day old RT-S broke down last night on the way home and I had to have it TOWED. Came out of a regular left turn and the dash started flashing the VSS icon and the DPS icon, my power started faltering and clearly I had lost the power steering--then it said "Limp Home Mode". THANK GOODNESS I read the whole owners manual the night I brought it home so I could tell the tow driver how to put it on the flatbed without damaging anything, but I was sure crushed. The dealer was closed and locked up so it was towed to my home, and now I have to get it there this morning. I sure hope this is a fluke and not a portent of problems to come! I never had my 12 yr old Intruder towed...
 

·
Registered
Joined
·
91 Posts
Wow, I would be truely crushed if that happened to me. I love Billie, my spyder, she has 1,970 miles. I have only had her for a week, purchased used and other than some squeaky brakes, the only issues I have had exist between the seat and the handlebars. I hope your new baby will be up and working again in no time.
 

·
Registered
Joined
·
504 Posts
I don't know how the RT's act in limp home mode but after my new DPS unit was installed the dealer didn't have the updated software so I was about 30 miles from home when my RS gave me that error and went into limp home mode. The biggest problem I had riding it on home was if you reved the engine past something like 2,500 rpm it would start cutting out but I rode it home and then on to the dealer the next day to get the new software update and mine has been fine since. I thought that was what the limp home mode was intended to do.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #5 ·
Hooray, my RT-S is back home! The service manager definitely put a priority on resolving my issues today; it was obvious they felt terrible this happened to me 3 days out from delivery. They had to re-calibrate the computers and order a part for the analog tach, which has been registering about 2000 rpm's below the digital tach. They took it for a 40 mile ride and felt it was safe for me to take home tonight. The temp was 103 when I picked it up and I can't wait for my cooling vest to arrive next week!
@Corybud--yes, I knew I could ride it in Limp Home mode but the system won't let you drive over 25-30 mph in Limp Home and traffic on the road I broke down on was 45-50 mph. If only I had broken down on some slower road, I could have avoided the tow truck fees!
 
1 - 5 of 5 Posts
Top