Can-Am Spyder Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Enjoying my new to me 2014 RS-S with 9K on the odometer. But the gauge cluster is acting up. If anyone has any tips that would be great!

Safe riding!

Randy
 

·
Super Moderator
Joined
·
1,094 Posts
Welcome.
Exactly what about the display is "acting up" ?

My first wild guess is to check the battery and it's main cable connections.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hey thanks, and thanks for the reply!

I did read lots about the touchy voltage and so charged up and installed a brand new battery etc with no luck. (although I haven't done a great job checking the cable connections other than the battery terminals since they are hard to really look at..)

Every time I start the machine the display flickers as it goes through the normal start up routine, then starts out in the lowest daytime brightness setting. I have to brighten the display in the menu every time I start it. Doesn't seem like a very common issue from what I've found so far.

Next is remove the cluster and clean the rear plug connections and make sure the plug is tight.

Pretty big cost for a new display just to save going through the menu each time to brighten the display, but it is annoying.

Cheers!
 

·
Super Moderator
Joined
·
1,094 Posts
You aren't starting it inside a garage or other structure.....are you ?
My RT does that and it is perfectly normal.
It "corrects" itself when it actually "sees" the sun for a minute.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Sadly no. Can't see the info outside in the light from start up and it doesn't get brighter without manually doing so.
 

·
Super Moderator
Joined
·
1,094 Posts
Sadly no. Can't see the info outside in the light from start up and it doesn't get brighter without manually doing so.
Well then the light sensor is:
Broken
Unplugged
Covered up by something.

Wish I knew where it was located but I don't.
Hopefully someone else will.

Wild idea: is there possibly a "day", "night" and an "auto" setting available ?
 
1 - 7 of 7 Posts
Top