Can-Am Spyder Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter · #1 ·
my bike is at the dealer right now for the 4th time for transmission problem no gear or throttle response down shifting and losing the gear have to turn off bike pull out key wait 2 /3 minutes re start and you can drive away. So now they have replaced the clutch assembly and solenoids (up and down shifting solenoids) Tech took out for ride and after 8 miles had same problem, And also could not shift out of 1st gear all the way back to shop. So get this now they think it is the ground wire missing (I know there was a recall on this) 1st dealer said it was done.(by the way he is a snake) and 2nd dealer said he needs to put it in. My question is what problem does the missing ground wire cause Thanks for any input Bill Steele
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #2 ·
transmission problem

Well got bike back today 7 17 10 seems the ground strap did the trick between me and the tech we rode the bike about 200 miles today and there was no problem let the bike down shift it self, let it get hot and idle awhile and drove etc. problem seems to be resolved Any body in the tri state area Mass. N.H. and Vt. Stay away from Keene Motorsports in New Hampshire They said they did all of the recalls and they did none of them. The ground strap was never put in also the steering recall not done. But they charge BRP as though they did them. Have also spoken to 3 other persons and they have been screwed by Keene Motorsports on work charged for and not done Real sleezy Dealership.
 
1 - 4 of 4 Posts
Top