Can-Am Spyder Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello My name is Glen Miller from Manitoba. I purchased a 2011 Can Am Spyder with 1000KM and it will not start. When I push the starter button (what I believe to be the starter solenoid under the seat on the left hand side forward of the battery) the starter solenoid clicks once and sometimes twice but starter dose not operate. can anyone offer some sugestions on what to do to trouble shoot his problem?
Please reply
Glen
 

·
Super Moderator
Joined
·
1,031 Posts
Welcome Glen.

No different than any other gas powered vehicle.

The battery is dead or there is a loose main battery cable.

There are a few more exotic possibilities but 99.5% of the time it's the battery.
 

·
Registered
Joined
·
21 Posts
Twice for me it’s been the battery.
Both times I could have sworn it was something else. Seemed like battery wasn’t that bad——
Also the type of battery used goes bad quick if you leave key on accidentally ——
 

·
Registered
Joined
·
1 Posts
I have a similar problem with my GS but when I hit the start button it clicks and everything goes dead. Checked the battery but it is fully charged. Anybody got any suggestions? Frank Scotti from Canada
 

·
Super Moderator
Joined
·
1,031 Posts
I have a similar problem with my GS but when I hit the start button it clicks and everything goes dead. Checked the battery but it is fully charged. Anybody got any suggestions? Frank Scotti from Canada
Same answer as reply #2 above.
Try to start it and then LEAVE THE KEY ON when it fails and measure the voltage at the battery posts........and then on the connectors attached to the posts. There is a difference.

And if both of those are OK, then follow both of the main cables and check the connection at the OTHER end.
 
1 - 5 of 5 Posts
Top