Can-Am Spyder Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Howdy! from south Georgia! I bought my automatic RTS in May 2010. My bike started having transmission problems at 2000 miles, exactly as the recall described. After a long wait, (the dealer said CanAm wasn't sending the new transmission) they put in a "new" one and things went well until 2 weeks ago. I have 14,000 miles on the bike now. The bike is doing the exact same thing again. I believe they are simply rebuilding the transmissions and have not actually fixed the problem. The bike doesn't want to shift from first,second, or any gear for that matter. Being a single woman riding alone this is very distressing. Anyone else having this trouble? How did ya'll resolve it? Also, I'd love to find some other spyder folks in my area to ride with. Thanks!
 

·
Registered
Joined
·
1,033 Posts
Welcome, Sandi! Sorry to hear about your returning issue. Call the dealership and make some noise - they should fix it again, if its the exact same issue.

I'm in Oklahoma, so a meet and greet is a bit of a stretch, but I'm sure there are some folks around your area... though I can't come up with a name off the top of my head!
 

·
Premium Member
Joined
·
3,861 Posts
Hi Sandi! :D
I've got an 2010 RT A&C up here and my SE 5 has been working great! I'd go right back to the dealer (Thanks Sassa! :D) and let 'em know that they've had their practice swings; now it's time to step up the the plate for real! :cool:
[email protected] might be a good place to ask about getting some help in resolving this... the follow's name is "Carlo" and his job is doing exactly what you need him to do for you! Giood luck!



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 
1 - 3 of 3 Posts
Top