Can-Am Spyder Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2010 RT the multi functiongauge display goes out while driving, then it will recycle and come up in the start-up page. No contol buttons work while the display is out. I have taken it to the dealer twice but they cannot find anything wrong. Has anyone else had this problem.
 

·
Registered
Joined
·
306 Posts
I have a 2010 RT the multi functiongauge display goes out while driving, then it will recycle and come up in the start-up page. No contol buttons work while the display is out. I have taken it to the dealer twice but they cannot find anything wrong. Has anyone else had this problem.
I've heard of this on other 2010 RT. Can you make the screen go blank with a light touch across the screen? A number have reported that they can get it to go blank with a light touch. This may help the dealer diagnose the problem easier.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks for the reply but it goes out on its own. It does have a line of code across top line of screen that says lcd_reset.cmd (or something like that).
 

·
Registered
Joined
·
5 Posts
I assume that the speedo and tach keep working ..... there is an intermittent power connection supplying the LCD portion of the gauge - this is common. Gauge package should be replaced.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
The dealer found a wire feeding power to the unit was broken and replaced it . If the problem continues I'll have them check the power supply. Thanks for the reply.
 
1 - 6 of 6 Posts
Top