Can-Am Spyder Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
Anyone have trouble with their rear suspension? Mine has leaked since it was new three months ago. First they told me it was the shock and they ordered the shock. Then when the shock came in they saw a bulletin on a fitting that leaks from the factory. They replaced the fitting but it still leaks. I'm having them replace the shock now.

Also someone at another dealer said never use a power compressor on the rear suspension. Always use a hand pump because the power compressor will blow the seals out of the shock. Then had another guy that's not true. Who knows what to believe anymore. All I know is I love riding the thing so the little problems are just that - little problems.
 

·
Registered
Joined
·
570 Posts
I could see an air compressor over filling the rear shock due to the small volume of air. I have the automagic shock so have not had this problem.
 

·
Registered
Joined
·
76 Posts
Shock Failure

We had the compressor go bad at 12K miles. When the compressor was replaced, the shock was deemed bad. Waiting on my new shock now. Funniest thing, aired up to about 40 lb, and it behaved like it was on spring only. Air it up by the pushbutton, and it shows the pressure going up, but no change in the feel of the suspension. Now I wonder how long the whole thing has been bad or marginal.Oh, first thing I noticed about the compressor was the suspension quit "spitting". So all you auto RTS folks out there, could be a heads up.

Spyderless for now, Patrick
 
1 - 3 of 3 Posts
Top