Can-Am Spyder Forums banner
1 - 5 of 5 Posts

· Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
2008 SE
24k miles

My Spyder has developed a rattling noise when I let off of the gas. I searched the forums and do not see anything similar. The mechanic at the dealer I use has no idea what could be causing it, and cannot discern where it originates. He put the machine up on a stand to allow the rear wheel to spin and simulate on the road travel. Roll on the throttle, everything is find. Let go and rattle, rattle, rattle. The cycle performs well. Good acceleration. Good shifting. Just this noise whenever I let off the gas.

Any ideas? I don't want him to tear everything apart without an idea of where to go with the exploratory surgery.
 

· Registered
Joined
·
303 Posts
It's hard to tell where the rattle is coming from but a few have reported rear bearings rattling or vibrating as the power is removed. If you have a Hindle exhaust check the heat shield, the rivies are well known to come lose and start rattling.

Good luck finding the cause!
 

· Registered
Joined
·
5 Posts
Hi,

I have the same 2008 SE model. Bought it this year around 20k miles. Everything was fine for 2500 miles than I started experiencing the same thing. Very loud metallic noise when decelerating, nothing when accelerating. I feel it as it's coming from the gearbox. Still haven't went to the dealer to check it but will do soon as it's kind of concerning. HAve you identified the source in the meantime?
 

· Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
Hi,

I have the same 2008 SE model. Bought it this year around 20k miles. Everything was fine for 2500 miles than I started experiencing the same thing. Very loud metallic noise when decelerating, nothing when accelerating. I feel it as it's coming from the gearbox. Still haven't went to the dealer to check it but will do soon as it's kind of concerning. HAve you identified the source in the meantime?
Yes. They replaced the entire engine/transmission under warranty. It was the bearing on the shaft between the engine and transmission. As you let off gas, it would wobble and rattle.
 

· Registered
Joined
·
20 Posts
Discussion Starter · #5 ·
10k miles on replacement

Yes. They replaced the entire engine/transmission under warranty. It was the bearing on the shaft between the engine and transmission. As you let off gas, it would wobble and rattle.
Transmission has failed again. 10k miles and now out of warranty. Dealer shop seems scared to tackle rebuilding.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top