Can-Am Spyder Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 2011 Spyder Rt SE 5 with 5,400 miles on it, I bought it this past January from a dealer with 2,379 miles on it, since I started riding it, i keep getting code P1130 and P1036, first time I replaced Map Sensor and both hoses with parts from BRP, I replaced both spark plugs, both O2 sensors, and fuel filter, had code cleared first time and bike went 1,500 miles before same codes came back on ,I recently had code P1130 cone on and I replaced O2 sensor on left side, now code P1036 came back on, bike runs great, no issues, but getting very annoying to keep spending $20 to go to local dealer to have codes cleared, anybody have any idea why these codes keep coming up ? Thank you in advance for any information you all can give !!!
 

·
Super Moderator
Joined
·
1,135 Posts
By now it is likely that you have spent WAY more money on parts than you would have spent on just letting the dealer fix it........maybe. Another alternative, since it seems to run great, is to just ignore the codes.

Does it have any aftermarket engine modifications........like pipes or air filter ??

Does it seem to use a LOT of oil.......or is the coolant level going down ??
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
By now it is likely that you have spent WAY more money on parts than you would have spent on just letting the dealer fix it........maybe. Another alternative, since it seems to run great, is to just ignore the codes.

Does it have any aftermarket engine modifications........like pipes or air filter ??

Does it seem to use a LOT of oil.......or is the coolant level going down ??
By now it is likely that you have spent WAY more money on parts than you would have spent on just letting the dealer fix it........maybe. Another alternative, since it seems to run great, is to just ignore the codes.

Does it have any aftermarket engine modifications........like pipes or air filter ??

Does it seem to use a LOT of oil.......or is the coolant level going down ??
Thank you for your reply, coolant is good , oil is fine, regular air filter, Akrapovic exhaust was on when I purchased it, bringing to dealer is out of question, 8 month wait, by the time I can bring it in, my 2022 Spyder F3 Limited I ordered will be in, thanks anyway
 

·
Registered
Joined
·
13 Posts
I have a 2011 Spyder Rt SE 5 with 5,400 miles on it, I bought it this past January from a dealer with 2,379 miles on it, since I started riding it, i keep getting code P1130 and P1036, first time I replaced Map Sensor and both hoses with parts from BRP, I replaced both spark plugs, both O2 sensors, and fuel filter, had code cleared first time and bike went 1,500 miles before same codes came back on ,I recently had code P1130 cone on and I replaced O2 sensor on left side, now code P1036 came back on, bike runs great, no issues, but getting very annoying to keep spending $20 to go to local dealer to have codes cleared, anybody have any idea why these codes keep coming up ? Thank you in advance for any information you all can give !!!
 

·
Registered
Joined
·
38 Posts
Had a similar problem with a 2011 a few years ago. Fortunately, it was still under warranty when the problem started, so it went to the dealer - several times. Code would clear periodically, then start up again. Finally gave up and bought a new one. Never did figure out what the problem was! Enjoy your 22!
 
1 - 5 of 5 Posts
Top