Can-Am Spyder Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi Guys and Gals,

So my question stems from a trip out to the garage to tinker with the Spyder. I noticed that the OIL LIGHT Icon comes on along with all of the other lights when you first turn the key to on but not starting the engine. I believe that this process shows you that the light is not burned out. The light never comes on again and I just wanted to make sure that this is normal.

In my experience, on other vehicles, the oil light will stay on until the engine produces enough oil pressure to shut this light off. So when the vehicle is turned to the ON position but engine is not running, the oil light should be on? Mine only comes on when the ignition is first turned on. Is my oil pressure sensor faulty?

Thanks,

Chris
 

·
Registered
Joined
·
6 Posts
No on any of my vehicles. It is just an idiot light. Comes on with the rest of them to show it is working then doesn't come on again until it thinks there is a problem.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Thanks. I thought so but wasn't sure. Either you and I have a problem with our machines or this is normal!
 

·
Super Moderator
'17 RT Limited
Joined
·
1,253 Posts
In my experience, on other vehicles, the oil light will stay on until the engine produces enough oil pressure to shut this light off.
Yes. And that is exactly what the Spyder is doing too.......right ?
Mine takes just a second after the engine is started to go out.

Maybe I don't understand the question.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
I only see the light come on when I first turn the key to on, and I only see it for a second. after that, it never comes on again.

My question is,.....shouldnt I see the light on when I have key on but engine isnt running? then....as soon as I start it and the engine builds oil pressure, then Light would turn off?
 

·
Super Moderator
'17 RT Limited
Joined
·
1,253 Posts
I only see the light come on when I first turn the key to on, and I only see it for a second. after that, it never comes on again.

My question is,.....shouldnt I see the light on when I have key on but engine isnt running? then....as soon as I start it and the engine builds oil pressure, then Light would turn off?
Yes, that's how it should work.
Your use of the phrase "it never comes on again" is confusing me.

The oil pressure light should come on as a part of the lamp test along with all of the other warning lights......
and then it should STAY on until you start the engine, unless maybe you immediately restart it after it has been running and there is still some pressure there.

It sounds to me like your oil pressure warning circuit is NOT working.
You should get it fixed.
Might be just a wire loose.
 
1 - 6 of 6 Posts
Top