Can-Am Spyder Forums banner
1 - 12 of 12 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi folks, I have a 2011 Spyder RT Limited that is having problems with the screen going blank. It starts great but usually no screen comes on. Doesn't affect anything other than turn signals and radio. After I ride a few miles it usually comes on but will eventually start sending error codes like engine failure or brake failure or DPS failure. There's nothing actually wrong, just false codes. My mechanic clears them but they come back on within a few miles. Only thing we've had done is brakes bled.
 

· Super Moderator
'17 RT Limited
Joined
·
1,897 Posts
It is highly likely that:
Your battery is getting weak.
There is a bad connection at one end of a main battery cable.
OR
The charging system is not keeping the battery charged enough.
One or all of the above may be present.

The tests for those things are pretty simple and require only a multi-meter.
It is too bad that most "mechanics" have no understanding of electricity.
You might need a new mechanic.

IF......the battery is over 5 years old, you definitely should start with a new fully charged battery.
 

· Registered
2018 Can Am F 3 Limited 6 speed
Joined
·
203 Posts
I would start with a battery check. I'm surprised your mechanic dig not do a load test while you were there getting the codes cleared. Takes no time at all.

Multi-meters are on expensive and a useful tool to have , or I guess you could shell out the price of a metre or more to pay a bloke to test it I guess.

If you have no clue on how to do this I found this for ya,
 

· Registered
2017 RTL
Joined
·
89 Posts
Hi folks, I have a 2011 Spyder RT Limited that is having problems with the screen going blank. It starts great but usually no screen comes on. Doesn't affect anything other than turn signals and radio. After I ride a few miles it usually comes on but will eventually start sending error codes like engine failure or brake failure or DPS failure. There's nothing actually wrong, just false codes. My mechanic clears them but they come back on within a few miles. Only thing we've had done is brakes bled.
I will say it is a weak battery. Try charging the battery to full and load test it. A weak battery on a Spyder will cause all sorts of codes and
the black screen you refer to.
 

· Super Moderator
'17 RT Limited
Joined
·
1,897 Posts
So I took my ride to Ridenow Powersports and they think it is battery too but battery is on backorder until March. Any replacement battery as good or better than oem?
Any "name brand" AGM type that is listed as an exact replacement should be fine.
Call around to other motorsports shops and battery stores.
Maybe even auto parts stores.
 

· Registered
2018 Can Am F 3 Limited 6 speed
Joined
·
203 Posts
Did you take anything onboard from post 3? ....................
Did the tech remove , clean both the terminal and the battery posts so they are clean and bright then refit.
Pop a multimedia on it?

Or wiggle it and go himmmm....?
 

· Registered
2017 RTL
Joined
·
89 Posts
So I took my ride to Ridenow Powersports and they think it is battery too but battery is on backorder until March. Any replacement battery as good or better than oem?
Go to LamonsterGarage.com they are an after market Spyder accessories and repair shop. They will have a battery in stock to fit your Spyder.
Ryde safe and enjoy the ryde
Artie
 
1 - 12 of 12 Posts
Top