Can-Am Spyder Forums: The Y-factor Community - Search Results
Advanced Search
Showing results 1 to 5 of 5
Search took 0.00 seconds.
Search: Posts Made By: motodad85
Forum: Can-Am Spyder RT Discussion   08-06-2019, 11:01 AM
Replies: 7
Views: 607
Posted By motodad85
Fixed

Thank yall (Texas thing) found a bad fuse, always the simple things. I did not know that there was a front fuse box.
Forum: Can-Am Spyder RT Discussion   08-06-2019, 09:51 AM
Replies: 7
Views: 607
Posted By motodad85
Yes I have disconnected the battery and when I...

Yes I have disconnected the battery and when I press the start button with foot on brake nothing happens.
Shows that it is in Neutral with parking brake on

Thank you for all the help
Forum: Can-Am Spyder RT Discussion   08-02-2019, 01:17 PM
Replies: 7
Views: 607
Posted By motodad85
No start

When the tire blew I was doing about 70mph, all over the road, but I got it to the side of the road safe, It started up when the wrecker got there, but when we unloaded it it wouldn't
When I turn...
Forum: Can-Am Spyder RT Discussion   08-02-2019, 07:40 AM
Replies: 7
Views: 607
Posted By motodad85
Have not tried to disconnect the battery yet, It...

Have not tried to disconnect the battery yet, It will not come out of the Safety screen, Mode button does nothing
Forum: Can-Am Spyder RT Discussion   08-01-2019, 09:26 AM
Replies: 7
Views: 607
Posted By motodad85
HELP no start

New to the Forum and my 2012 Spyder RT. This bike has been running fine until the back tire blew. I changed it all out, not as easy as I thought it would be, Now the bike will not start. Mode button...
Showing results 1 to 5 of 5

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome