New to this form - Can-Am Spyder Forums: The Y-factor Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-12-2020, 05:12 PM Thread Starter
Junior Member
 
Join Date: May 2020
Posts: 2
New to this form

Hey Guys
I have a 2014 Spyder STS I just replaced my original battery with a new one. Back in March. Been riding the bike for over a month now and the battery won’t hold a charge. Had the battery checked they said it was good. And the bike is charging. But the battery is not holding enough charge to start the bike.
Dave57 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-13-2020, 06:14 AM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 576
Three likely possible causes:
The battery wasn't fully charged in the beginning. The Spyder, like most vehicles these days, will NOT fully charge a dead battery.
Could be a loose main battery connection interfering with the charging and starting.
Could be that whoever "tested" the battery doesn't know what they are doing.

I suggest that the first thing you should do is buy or borrow a small automatic tender type battery charger and connect it until the "done" light comes on. If after 24 hours the "charged" light does not come on, then it is very likely that your new battery is bad.

You haven't added any new accessories lately have you ?

P.S. I deleted your other post so that this discussion won't be scattered all over.

'17 RT Limited

Last edited by Easy Rider; 05-13-2020 at 06:16 AM.
Easy Rider is offline  
post #3 of 3 (permalink) Old 05-13-2020, 05:32 PM Thread Starter
Junior Member
 
Join Date: May 2020
Posts: 2
Hey guy
Thank you for answering my situation. No I have not added any accessories to the bike. I have been using a battery tender To bring the battery up to a full charge to start the bike. Iím going to ride the bike into work tomorrow so letís see if the charge will hold. Iíll let you know how that works out. Thanks
Dave57 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Spyder Forums: The Y-factor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome