I have a new 2018 CanAm Spyder with problems - Can-Am Spyder Forums: The Y-factor Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-25-2018, 01:37 PM Thread Starter
Junior Member
 
Join Date: Oct 2018
Posts: 1
I have a new 2018 CanAm Spyder with problems

Just received my new Spyder and I live in Northern Virginia. Its starting to get chilly here so I want to get some trike time before winter hits. I just retired from professional life and I am also a a retired Army officer.

Major problem is I cant get it to start. Just dies right away. I also cannot set the parking brake.
Hopefully I will be on the road soon.

Can Am Kathy
kagibson is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-25-2018, 05:18 PM
Senior Member
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 432
Both of those symptoms could be caused by a loose battery cable of a very low battery charge.

BUT.....you have a warranty, including towing to the shop if necessary.

I suggest that you USE it.

'17 RT Limited
Easy Rider is online now  
post #3 of 3 (permalink) Old 12-16-2018, 08:51 AM
Junior Member
 
Join Date: Sep 2018
Posts: 2
Why oh why do so many people post a thread with a problem they are having but almost NEVER post what happened in the end? I will never understand this if I live to be 100 years old.

Rick H.
Rick H is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Spyder Forums: The Y-factor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome