Spyder won't start ??? - Page 3 - Can-Am Spyder Forums: The Y-factor Community
 4Likes
Reply
 
LinkBack Thread Tools Display Modes
post #21 of 22 (permalink) Old 03-19-2019, 11:43 PM
Junior Member
 
Join Date: Feb 2019
Location: Bendigo, Victoria Australia.
Posts: 6
Yep, know this 'refusing to start' problem well. My 2009 Se5 has displayed every dumb message and flashed every red light possible in the months I have owned it, but not since I changed my start procedure. My non-starting appears to have been solved by pressing the brake pedal before putting the key in it's switch, then simply following the normal start procedure while the brake pedal remains pressed.

Good luck! They are lots of fun, hey!
RazzleH is offline  
Sponsored Links
Advertisement
 
post #22 of 22 (permalink) Old 03-29-2019, 08:18 AM
Senior Member
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 377
Quote:
Originally Posted by RazzleH View Post
pressing the brake pedal before putting the key in it's switch, then simply following the normal start procedure while the brake pedal remains pressed.

Good luck! They are lots of fun, hey!
Great idea.
This certainly eliminates forgetting that the brake NEEDS to be pressed......which occasionally is a problem that I still have.
Now to try and establish an new "automatic" routine !!!
RazzleH likes this.

'17 RT Limited
Easy Rider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Spyder Forums: The Y-factor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome