2008 SM5 RS Starter relay failure?? (cross-post) - Can-Am Spyder Forums: The Y-factor Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-11-2019, 07:18 AM Thread Starter
Junior Member
 
Join Date: Mar 2008
Location: PA
Posts: 4
2008 SM5 RS Starter relay failure?? (cross-post)

Posting here as well as the other thread...

Went to start the Spyder after a lengthy rest. Only 8K miles ion this machine. Always on battery tender, fresh fuel, checked voltage (12.8), etc. Key on, fuel pump cycles, safety message displays. Push M button, hit starter. ** Fuel pump runs, starter DOESN'T make a sound, fuel pump stops, safety message displays all over again. Everything checkable checks normal electrically. Again, starter doesn't click, turn, nothing.

I'm thinking starter relay, but need to know:

Is this a common problem?

Where is the starter relay so I can check/replace?

And, of course, if my diagnosis is wrong, what do I check next?

TIA
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-14-2019, 11:58 AM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 480
Quote:
Originally Posted by [email protected] View Post
Posting here as well as the other thread...
PLEASE don't do that again.
Having the discussion going in more than one thread just confuses matters for everybody.
Thanks.

'17 RT Limited
Easy Rider is online now  
post #3 of 4 (permalink) Old 07-14-2019, 02:07 PM Thread Starter
Junior Member
 
Join Date: Mar 2008
Location: PA
Posts: 4
Sorry for the breach of conduct, but it's been a long time since I posted on this forum, though I was VERY active some years ago, and I'm trying to get a useful response. I thought maybe the techie folks might look at this one instead of the older model RS forum. Still seeking a usable answer which is:

Are issues with the starter relay or solenoid a common problem? and, which relay is the starter relay?

I have the owner's manual that has a troubleshooting schema, but it hasn't been productive of an answer.
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 07-14-2019, 02:39 PM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 480
Quote:
Originally Posted by [email protected] View Post
Still seeking a usable answer which is:

Are issues with the starter relay or solenoid a common problem?
NO.

AND.....I gave you what I think is better, more useful information in the OTHER thread.
Did you see that ??

'17 RT Limited
Easy Rider is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Spyder Forums: The Y-factor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome