Dash Cluster keep going out - Can-Am Spyder Forums: The Y-factor Community
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 10-14-2020, 06:57 PM Thread Starter
Junior Member
 
Join Date: Aug 2016
Location: Austin, TX
Posts: 5
Exclamation Dash Cluster keep going out

Trying to find out why on my 2015 Spyder RT Limited the Dash Cluster keep going out
White Hawk is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 10-17-2020, 11:22 AM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 713
More details are needed.
Wild guess is it sounds like a loose connection.
But exactly what is happening and what, if anything, have you done to try and fix it ??

'17 RT Limited
Easy Rider is online now  
post #3 of 9 (permalink) Old 10-18-2020, 11:19 AM Thread Starter
Junior Member
 
Join Date: Aug 2016
Location: Austin, TX
Posts: 5
Quote:
Originally Posted by White Hawk View Post
Trying to find out why on my 2015 Spyder RT Limited the Dash Cluster keep going out
The bike wouldn't start end up having it towed home put new battery in it it started fine the next day go on it and went to another PGR mission and on the way it started show showing dynamic steering error on cluster when I tried to start it again it came up in limp home mode but wouldn't start then the cluster wouldn't light up towed to dealer and they told me the error codes all pointed to lost communication to cluster this is the second time that this has happened @$898.00 for the cluster plus installation it getting to the point that I am looking at other rides now
White Hawk is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 10-19-2020, 10:21 AM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 713
In the specific situation given in your post.......I think it is HIGHLY likely that your most recent problem was due to low battery voltage.
Either the new one wasn't fully charged OR there is a loose or corroded main power connection OR the new battery is bad........OR the charging system isn't keeping the battery up. You should test it now.

It is too much of a coincidence that the "communication" failure occurred so near to the time that the battery went flat.

How long between the failures ?
There should be SOME warranty on the replaced part.

'17 RT Limited
Easy Rider is online now  
post #5 of 9 (permalink) Old 10-19-2020, 09:58 PM Thread Starter
Junior Member
 
Join Date: Aug 2016
Location: Austin, TX
Posts: 5
BPR rejected covering it under warranty they only allowed a year and a half on the first one and my five year expired 3 months ago Also the shop istelling the battery is good and the everything on the wiring harness check out good???
White Hawk is offline  
post #6 of 9 (permalink) Old 10-20-2020, 12:29 PM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 713
Sad.
Did you keep the old part this second time ?

Saying that the battery "is good" is not also saying that it was fully charged.
It also is not saying that they checked the charging voltage.

'17 RT Limited
Easy Rider is online now  
post #7 of 9 (permalink) Old 10-20-2020, 12:45 PM Thread Starter
Junior Member
 
Join Date: Aug 2016
Location: Austin, TX
Posts: 5
Not yet there telling me they won't have the bike fixed until the 28th this month. I am go the power sports (shop) where I took it to be repaired tomorrow and will ask them for it and I will ask the about the charging system and the battery tomorrow
White Hawk is offline  
post #8 of 9 (permalink) Old 11-05-2020, 04:51 PM Thread Starter
Junior Member
 
Join Date: Aug 2016
Location: Austin, TX
Posts: 5
Easy Rider I kept the old Dash Cluster part is there some place the I can get it repaired for a spare?
White Hawk is offline  
post #9 of 9 (permalink) Old 11-06-2020, 08:01 AM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 713
Quote:
Originally Posted by White Hawk View Post
Easy Rider I kept the old Dash Cluster part is there some place the I can get it repaired for a spare?
I doubt it.
This is incase it fails again soon in exactly the same way.......you can take it back to the shop and insist that they refund your money for a part that wasn't the problem and put the old one back in.

'17 RT Limited
Easy Rider is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Spyder Forums: The Y-factor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome