ST limited 2013 draining battery during ride - Can-Am Spyder Forums: The Y-factor Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-28-2020, 05:38 AM Thread Starter
Junior Member
 
Join Date: Jun 2020
Posts: 3
Hello everyone.
Guys, I need some help to find solution. I'm basically new can am spyder user and I'm sure is not only problem with my one.
I bought Spyder St limited 2013 not long time ago. Instaled new battery but the problem is with the battery drain. I can't even go outside the village bacause during the ride machine sniffing the electricity from battery so fast and the ride is ending on the side of the road. 😭😭😭
I can't believe there is no stator.

Thanks a lot for any useful info..

Last edited by AdiM198; 06-28-2020 at 07:06 AM.
AdiM198 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-28-2020, 02:40 PM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 713
Welcome.

First you need to put a meter across the battery while it is running and see what the charging voltage IS.

Assuming that it is way low, then you probably need to pay a Spyder shop to do a "diagnostic" on it and give you an estimate for repairs.

This isn't a common problem......so not much information floating around about a fix.
There may be more than one possible cause.

'17 RT Limited
Easy Rider is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Spyder Forums: The Y-factor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome