Spyder ST won't start after connecting battery.. - Can-Am Spyder Forums: The Y-factor Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-20-2020, 06:09 AM Thread Starter
Junior Member
 
Join Date: Jun 2020
Posts: 3
Spyder ST won't start after connecting battery..

Hello guys.
Looking for some advise. My spyder St ltd won't start.
I connected fully charged battery ( nearly new ) after 1.5 months not to touching my spyder and when turning key on is nothing happen on dashboard. Even main screen is off.
Only cooling fan start working and front lights are on. Have no idea where to look for the problem..

Thanks in advance...
AdiM198 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-20-2020, 12:16 PM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 675
Sorry you are having trouble.
No easy way to diagnose this problem without being there.
A shop visit likely will be required.

I don't think the cooling fan should run when the engine is COLD.

And for future reference, if you have access to power where the bike is parked, there is NO reason to take the battery out or to disconnect it while a battery tender is in use.

Even thought the screen is dead, have you gone ahead and tried to complete the normal starting sequence anyway ??

'17 RT Limited
Easy Rider is offline  
post #3 of 5 (permalink) Old 06-23-2020, 10:08 AM Thread Starter
Junior Member
 
Join Date: Jun 2020
Posts: 3
Thanks for reply.
Things sorted. Battery cable was rusty in one place. After proper cleaning everything back to normal.

Have safe riding guys....

Last edited by Easy Rider; 06-23-2020 at 05:47 PM.
AdiM198 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 08-19-2020, 08:20 PM
Junior Member
 
TI3VOM's Avatar
 
Join Date: Aug 2019
Posts: 5
Did you have it on a trickle charger ?
TI3VOM is offline  
post #5 of 5 (permalink) Old 08-20-2020, 10:54 AM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 675
Quote:
Originally Posted by TI3VOM View Post
Did you have it on a trickle charger ?
Why do you ask ?
I hope not. A cheap trickle charger can do more harm than good.

'17 RT Limited
Easy Rider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Spyder Forums: The Y-factor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome