Park Brake Failure 2010 RT se5 - Page 2 - Can-Am Spyder Forums: The Y-factor Community
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 10-17-2020, 10:41 AM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 690
Quote:
Originally Posted by John Biggs View Post
I have a 2013 spyder the parking brake and wind screen both don't work the dealer said it is a faulty module that cost 600 save your money for parts .
Both are common failures with Spyders BUT this is the first I have ever seen where anyone claims that both can be caused by one common component.

Parking brake failures are usually the brake motor.
Windshield not moving usually is a physically broken bracket.

The only way I would let this dealer change out this "module" is if they are guessing with THEIR $600 and not yours.
That is, if the module doesn't fix the problem, you will not pay for it.

'17 RT Limited
Easy Rider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Spyder Forums: The Y-factor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome