Won't start - Can-Am Spyder Forums: The Y-factor Community
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-22-2019, 07:39 PM Thread Starter
Junior Member
 
Join Date: Oct 2019
Posts: 2
Won't start

I have a 2016 Spyder RT SE6, when I go to start it, I press the starter button
and every thing goes dead after going through the steps, what could be causing the problem? The spyder has 1,000 miles on it horn works and turn signals and brake lights work ok.
johnny2904 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-23-2019, 05:15 PM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 640
Welcome.

What you described are the classic symptoms of either a worn out battery OR a bad connection at one end of either of the main battery cables.

Of course, if it is still under an extended warranty, you should have a shop come and get it.

'17 RT Limited
Easy Rider is online now  
post #3 of 7 (permalink) Old 10-31-2019, 05:16 PM
Member
 
tibadoe's Avatar
 
Join Date: May 2013
Location: Virginia
Posts: 42
Garage
Could be a weak battery that's going bad or maybe just needs a good charge. Make sure battery cables are clean and tight. Make sure battery is fully charged and have it load tested. This will let you know the condition.

----
Joe
tibadoe is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 11-20-2019, 06:32 PM Thread Starter
Junior Member
 
Join Date: Oct 2019
Posts: 2
The battery had a bad cell, replaced the battery started right up.
Thanks
johnny2904 is offline  
post #5 of 7 (permalink) Old 01-08-2020, 08:47 PM
Member
 
Flamewinger's Avatar
 
Join Date: May 2018
Location: California
Posts: 44
Garage
Sounds like a loose battery connection as you get power with the key on and once you pull major apps from it the connection separates and you loose all power. Ive had it because of a corroded terminal. Nowadays it seems the battery terminals loosen easily as a lot of riders have this problem.

http://i290.photobucket.com/albums/l...3at90635PM.png
Susie - 2018 RT-Limited with 14400 miles so far . . .
'13 Spyder ST-L with 21k miles
'04 GL1800 with 91k miles
'97 GL1500 with 87k miles
'95 GL1500 with 102k miles
'89 GL1500 with 96k miles
'83 GL1100 with 117k miles
'81 Honda Silverwing with 36k miles
'79 Kaw 400LTD with 26k miles
GWRRA - 38 yrs - Life Member
AMA - 40 yrs
Just remember, if common sense is so common, why do few people have it?
Flamewinger is online now  
post #6 of 7 (permalink) Old 01-16-2020, 04:23 PM
Junior Member
 
Join Date: Jul 2019
Posts: 21
Believe it or not
Battery
Dlby77 is offline  
post #7 of 7 (permalink) Old 07-15-2020, 04:07 PM
Junior Member
 
Join Date: Aug 2018
Posts: 8
check the earth strap from the battery with a spanner, you will find it is not tight enough. When you try to start it, the dash dies. To prove it, locate the earth strap and get someone to start it whilst you watch and you should see a spark.
Dustproof is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Spyder Forums: The Y-factor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome