2015 RTS poor / no AM/FM radio reception - Can-Am Spyder Forums: The Y-factor Community
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 12-09-2018, 03:13 AM Thread Starter
Junior Member
 
Join Date: Sep 2018
Posts: 2
2015 RTS poor / no AM/FM radio reception

Radio reception is poor or non-existent for both AM and FM bands. This it is not a location issue because my Goldwing parked next to the Spyder gets great reception. I did check the antenna connection and ground and all appears fine. The sound system works fine with an Ipod. Any ideas?
scootrp is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 12-10-2018, 07:40 AM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 634
Quote:
Originally Posted by scootrp View Post
. I did check the antenna connection and ground and all appears fine.
Exactly HOW did you "check it" ?

Do you have a passenger intercom ?

When I had trouble with my audio, the VOX setting for the intercom was up too high, cutting out the other inputs.

'17 RT Limited
Easy Rider is online now  
post #3 of 7 (permalink) Old 12-12-2018, 02:42 AM Thread Starter
Junior Member
 
Join Date: Sep 2018
Posts: 2
I checked the connection by physically taking off body panels to get to the radio and antenna to verify connections.
Yes I have a passenger intercom and it works fine. As my initial post stated, the sound system works fine with an Ipod.
scootrp is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 12-12-2018, 07:05 AM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 634
Quote:
Originally Posted by scootrp View Post
I checked the connection by physically taking off body panels to get to the radio and antenna to verify connections.
No offense intended here but just looking at the connections is not good enough.

You need to check the cable and antenna itself with an ohm meter to be sure the center conductor at the radio is connected to the antenna mast.....and that the shield is connected to ground at both ends and is NOT shorted to the antenna.

My reception is not as good as my car.......but I didn't expect it to be.
It picks up "local" FM fine. I have not tried AM.....because I don't care about that.

'17 RT Limited

Last edited by Easy Rider; 12-12-2018 at 07:07 AM.
Easy Rider is online now  
post #5 of 7 (permalink) Old 06-15-2020, 04:36 PM
Junior Member
 
Tod Brogdon's Avatar
 
Join Date: Jun 2020
Posts: 1
Mine is the same way. Has done it since new. Will only pick up 2 or 3 stations scanning through every band.
Tod Brogdon is offline  
post #6 of 7 (permalink) Old 07-11-2020, 05:06 PM
Junior Member
 
popperchevy1947's Avatar
 
Join Date: Jul 2020
Location: Georgia
Posts: 1
fm radio

Mine doesn't work well either. It picks up ONE station & even that is static. I use my phone anyway but I do like the option sometimes.
popperchevy1947 is offline  
post #7 of 7 (permalink) Old 07-12-2020, 07:23 AM
Super Moderator
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 634
Quote:
Originally Posted by popperchevy1947 View Post
Mine doesn't work well either. It picks up ONE station & even that is static. I use my phone anyway but I do like the option sometimes.
IF.....you live in or near Metro Atlanta, your antenna is likely not connected right.
I got a LOT of stations when I was there. (FM)

If you live out in the Georgia "boonies"......then all bets are off !!

'17 RT Limited
Easy Rider is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Spyder Forums: The Y-factor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome