F3 power loss - Can-Am Spyder Forums: The Y-factor Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-12-2019, 01:55 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 1
F3 power loss

Hi , I have an F3 2015 with 22,000 km, have been experiencing some intermittent power loss issues while changing up, seems to clear up fairly quickly, wondering if anyone else had had any similar issues, thanks in advance
Nicandclivey is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-13-2019, 09:48 AM
Senior Member
 
Join Date: Mar 2017
Location: N. Central Florida
Posts: 390
Could be a LOT of things.

Have you kept up on routine maintanance ?.......like filters, fuel and air ?

Has a shop had a look at it recently ??

Could be a vacuum leak; vacuum hoses are a fairly common problem.

Then......how long have you had it ?
Mine will hesitate just a little bit when shifting UP if I accidentally move the throttle at the same time.

'17 RT Limited
Easy Rider is offline  
post #3 of 3 (permalink) Old 05-15-2019, 10:41 PM
Member
 
spydercowboy's Avatar
 
Join Date: Sep 2012
Location: Between Fort Worth and Wichita Falls Texas
Posts: 85
There was a technical bulletin about an alternator problem on our 018 F3. Just wondering if it's possible they could be related. That's in addition to the stuff listed above.

Do everything as if your life depends on it. It COULD!

American Legion Rider
spydercowboy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Spyder Forums: The Y-factor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome